Scheduled maintenance is still in progress. We will provide updates as necessary.
Posted Sep 12, 2024 - 08:44 EDT
Update
We are still working on our maintenance to improve our app's performance. We apologize that you were unable to check your bagels today at noon. We will notify you as soon as the maintenance is complete and the app is accessible again. Thank you so much for your patience.
Posted Sep 12, 2024 - 04:59 EDT
Update
Our maintenance is still ongoing, but we’ll be back online soon. We’ll let you know as soon as everything is up and running. Thanks so much for your patience!
Posted Sep 11, 2024 - 23:08 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 11, 2024 - 16:01 EDT
Update
We will be undergoing scheduled maintenance during this time.
Posted Sep 11, 2024 - 09:02 EDT
Scheduled
We are currently performing maintenance on our app to improve its performance. During this time, you won’t be able to access the app. Please check back in a few hours and we should be done! We apologize in advance for the inconvenience and thank you for your patience.
Posted Sep 11, 2024 - 16:00 EDT
This scheduled maintenance affected: CMB WW Application.